Cloudflare System Status

Investigating network congestion
Incident Report for Cloudflare
Resolved
Congestion has been addressed.
Posted Jan 13, 2015 - 06:42 UTC
Investigating
We're receiving reports of network congestion in Seattle.

Investigating.
Posted Jan 13, 2015 - 05:46 UTC
This incident affected: North America (Seattle, WA, United States - (SEA)).