Cloudflare System Status

TLS Handshake Errors for 1.1.1 DNS over HTTPS
Incident Report for Cloudflare
Resolved
This incident has been resolved and DNS over HTTPS service has returned to normal.
Posted 4 months ago. Apr 24, 2019 - 17:16 UTC
Investigating
Cloudflare is observing handshake errors for our 1.1.1.1 DNS resolver over HTTPS service.
Posted 4 months ago. Apr 24, 2019 - 16:52 UTC