Cloudflare System Status

DNS Resolution Issues
Incident Report for Cloudflare
Resolved
DNS resolution has returned to normal.
Posted 3 months ago. Jul 02, 2018 - 07:48 UTC
Monitoring
The issue is no longer occurring. We are currently monitoring this issue.
Posted 3 months ago. Jul 02, 2018 - 02:19 UTC
Investigating
Investigating issues with DNS when queried from Google’s recursive service (8.8.8.8).
Posted 3 months ago. Jul 02, 2018 - 01:45 UTC