Cloudflare System Status

Investigating network congestion
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Nov 09, 2014 - 15:01 UTC
Update
Most locations are now operating normally.
Posted Nov 09, 2014 - 14:53 UTC
Identified
DNS resolution is currently impacted in some locations. Working to mitigate.
Posted Nov 09, 2014 - 14:39 UTC
Investigating
We're receiving reports of network congestion. Investigating.
Posted Nov 09, 2014 - 14:19 UTC