Cloudflare System Status

Cloudflare is investigating Page Rule-related delays
Incident Report for Cloudflare
Resolved
This issue has been resolved.
Posted Oct 04, 2016 - 06:07 UTC
Investigating
Cloudflare's Page rule service delivery is still available; only Page Rule updates and changes are delayed.
Posted Oct 04, 2016 - 05:27 UTC