Cloudflare System Status

Investigating Network Related Issues in Mumbai
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 16, 2016 - 13:36 UTC
Investigating
We’re receiving reports of network related issues in Mumbai
Posted May 16, 2016 - 13:05 UTC
This incident affected: Asia (Mumbai, India - (BOM)).