Cloudflare System Status

Network Performance Issues in Manila
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Oct 15, 2016 - 03:55 UTC
Investigating
Cloudflare is observing network performance issues in Manila. We are actively working to reduce or eliminate any impact to Internet users in this region.
Posted Oct 15, 2016 - 01:16 UTC