Cloudflare System Status

Propagation of DNS updates delayed
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jul 12, 2015 - 21:24 UTC
Monitoring
Previously delayed record updates have now propagated. We are monitoring for any further delays.
Posted Jul 12, 2015 - 19:49 UTC
Investigating
User updates to DNS records in the past few hours are delayed. We are investigating.
Posted Jul 12, 2015 - 19:18 UTC