Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This issue has been resolved and have returned to normal.
Posted Feb 24, 2017 - 18:40 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted Feb 24, 2017 - 17:33 UTC
Investigating
We are observing delays in updates to DNS records. Cloudflare's DNS service delivery is still available: only DNS updates and changes are delayed.
Posted Feb 24, 2017 - 15:48 UTC