Cloudflare system status
Billing Maintenance
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 16 days ago. Feb 07, 2017 - 18:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 16 days ago. Feb 07, 2017 - 18:38 UTC
Identified
We are performing maintenance on our subscription services. For approximately 30 minutes you may see a delay in processing changes to subscriptions. All other services are operating normally. We will post an update once the maintenance is complete.
Posted 16 days ago. Feb 07, 2017 - 17:55 UTC
This incident affected: Cloudflare customer dashboard and APIs (Billing).