Cloudflare System Status

Network Performance Issues in London
Incident Report for Cloudflare
Resolved
This is issue is now resolved
Posted Jul 20, 2016 - 09:07 UTC
Monitoring
Performance has been improved and we are still monitoring the result.
Posted Jul 20, 2016 - 07:40 UTC
Investigating
CloudFlare is observing network performance issues in London. We are actively working to reduce or eliminate any impact to Internet users in this region.
Posted Jul 20, 2016 - 07:09 UTC
This incident affected: Europe (London, United Kingdom - (LHR)).