Cloudflare System Status

DNS Resolution and Propagation Delays
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and DNS resolution has resumed normal operation.
Posted 4 months ago. Nov 28, 2018 - 18:24 UTC
Identified
Cloudflare is investigating delays in updates to DNS records. These delays affect record changes and updates.

DNS resolution is operating with increased latency.
Posted 4 months ago. Nov 28, 2018 - 15:58 UTC