Cloudflare System Status

DNS update delays
Incident Report for Cloudflare
Resolved
This issue has been resolved.
Posted Sep 29, 2016 - 15:16 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted Sep 29, 2016 - 14:27 UTC
Investigating
We are observing delays of up to 30 minutes in updates to DNS records. CloudFlare's DNS service delivery is still available; only DNS updates and changes are delayed.
Posted Sep 29, 2016 - 14:10 UTC