Cloudflare System Status

Billing Maintenance
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Sep 22, 2016 - 21:04 UTC
Monitoring
Scheduled maintenance for our billing services. There may be delays when upgrading domains to a paid plan.
Posted Sep 22, 2016 - 20:52 UTC