Cloudflare system status
DNS Update Delays
Incident Report for Cloudflare
Resolved
This issue has been resolved and DNS updates have returned to normal.
Posted 14 days ago. Jul 04, 2018 - 17:46 UTC
Identified
The issue has been identified and a fix is being implemented. We will update once we have confirmed it is working.
Posted 14 days ago. Jul 04, 2018 - 17:11 UTC
Investigating
Cloudflare is investigating delays of up to 45 minutes in making updates to DNS records in all locations. DNS resolution is still performing correctly - only record updates and changes are delayed.
Posted 14 days ago. Jul 04, 2018 - 16:56 UTC
This incident affected: Cloudflare customer dashboard and APIs (Cloudflare.com).