Cloudflare System Status

DNS resolution degraded performance
Incident Report for Cloudflare
Resolved
Performance is back to optimal, worldwide.
Posted Nov 04, 2014 - 19:44 UTC
Update
Impact is mostly mitigated worldwide. More shortly.
Posted Nov 04, 2014 - 19:25 UTC
Identified
We are seeing degraded performance in DNS resolution in several locations worldwide.
Posted Nov 04, 2014 - 19:15 UTC
Investigating
We're receiving reports of network congestion. Investigating.
Posted Nov 04, 2014 - 19:08 UTC