Cloudflare System Status

DNS, Audit Log, Argo Tunnel, Spectrum Update Delays
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted about 1 month ago. Jun 18, 2019 - 22:13 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted about 1 month ago. Jun 18, 2019 - 20:10 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Jun 18, 2019 - 19:59 UTC
Update
Propagation delay for impacted services has now reached 2 hours
Posted about 1 month ago. Jun 18, 2019 - 18:52 UTC
Update
We are continuing to investigate this issue.
Posted about 1 month ago. Jun 18, 2019 - 18:35 UTC
Investigating
Cloudflare is investigating delays of up to 30 minutes in updates to DNS records, Audit Logs, Argo Tunnel and Spectrum. These delays only affect changes and updates.

Existing services are operating normally.
Posted about 1 month ago. Jun 18, 2019 - 18:19 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Spectrum, Argo Tunnel, SSL Certificate Provisioning, DNS Updates).