Cloudflare System Status

Network Performance Issues in Athens, Greece
Incident Report for Cloudflare
Resolved
We see no further issues since disabling this IX and we are marking this incident as resolved.
Posted 4 months ago. Jun 26, 2019 - 12:09 UTC
Monitoring
We have removed traffic from the IX that is causing the issue and are seeing improvement.
Posted 4 months ago. Jun 26, 2019 - 11:22 UTC
Identified
We have identified an issue with an Internet Exchange (IX) in the region, we have disabled the use of this IX until that issue is resolved.
Posted 4 months ago. Jun 26, 2019 - 11:22 UTC
Investigating
Cloudflare is observing network performance issues in Athens, Greece.

We are working to mitigate impact to Internet users in this region.
Posted 4 months ago. Jun 26, 2019 - 11:20 UTC
This incident affected: Europe (Athens, Greece - (ATH)).