Cloudflare System Status

Degraded performance in AMS
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 01, 2015 - 20:55 UTC
Monitoring
Degradation in AMS has been mitigated. We are monitoring closely.
Posted Jun 01, 2015 - 19:21 UTC
Investigating
We are investigating slow responses and errors in Amsterdam.
Posted Jun 01, 2015 - 19:09 UTC
This incident affected: Europe (Amsterdam, Netherlands - (AMS)).