Cloudflare System Status

Network Performance Issues in Zurich
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Oct 03, 2016 - 15:22 UTC
Identified
Cloudflare is observing network performance issues in Zurich. We are actively working to reduce or eliminate any impact to Internet users in this region.
Posted Oct 03, 2016 - 10:37 UTC
This incident affected: Europe (Zürich, Switzerland - (ZRH)).