Cloudflare System Status

Cloudflare Billing Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Dec 18, 2019 - 11:46 UTC
Identified
We have identified an issue and are working on a solution.
Posted Dec 18, 2019 - 10:45 UTC
Investigating
Cloudflare is experiencing problems in processing changes through our billing subscription service. All other services are operating normally.

We will provide an update once billing subscription services return to normal.
Posted Dec 18, 2019 - 08:21 UTC
This incident affected: Cloudflare Sites and Services (Billing).