Cloudflare System Status

DNS Update Delays in Singapore
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jan 20, 2018 - 14:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 20, 2018 - 13:29 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 20, 2018 - 13:28 UTC
Investigating
Cloudflare is investigating delays of up to 30 minutes in making updates to DNS records in Singapore. DNS resolution is still performing correctly - only record updates and changes are delayed.
Posted Jan 20, 2018 - 12:46 UTC
This incident affected: Asia (Singapore, Singapore - (SIN)).