Cloudflare System Status

Helpdesk Availability Issues
Incident Report for Cloudflare
Resolved
This issue has been resolved.
Posted 4 months ago. May 30, 2018 - 13:34 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted 4 months ago. May 30, 2018 - 12:23 UTC
Identified
The issue has been identified and a fix is being implemented. We will update once we have confirmed it is working.
Posted 4 months ago. May 30, 2018 - 09:51 UTC
Investigating
We are currently experiencing issues with customers unable to login to the Helpdesk dashboard and as such customers might have issues with submitting or viewing support tickets. You can still contact us via e-mail to support@cloudflare.com (using the address you registered your account with).

Enterprise customers can still reach us via live chat on the dashboard or via the emergency telephone line.
Posted 4 months ago. May 30, 2018 - 08:35 UTC