Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted about 1 month ago. Jul 17, 2019 - 18:33 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted about 1 month ago. Jul 17, 2019 - 18:10 UTC
Identified
Cloudflare is investigating delays of over 10 minutes in updates to DNS records. This delay also affects provisioning new Argo Tunnel instances by over 10 minutes.

DNS resolution and established Argo Tunnels are not impacted.
Posted about 1 month ago. Jul 17, 2019 - 17:29 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).