Cloudflare System Status

Investigating Network Related Issues in multiple colos.
Incident Report for Cloudflare
Resolved
An apparent outage for a major hosting provider caused connection timeouts to many CloudFlare customer origin servers.
Posted Jul 01, 2015 - 01:22 UTC
Identified
The issue has been identified.
Posted Jul 01, 2015 - 01:09 UTC
Investigating
We’re receiving reports of network related issues in multiple colos.
Posted Jul 01, 2015 - 00:42 UTC