Cloudflare System Status

Network Performance Issues in Mombasa
Incident Report for Cloudflare
Resolved
This issue has been resolved.
Posted Oct 16, 2016 - 08:12 UTC
Investigating
Cloudflare is observing network performance issues in Mombasa. We are actively working to reduce or eliminate any impact to Internet users in this region.
Posted Oct 16, 2016 - 06:23 UTC
This incident affected: Africa (Mombasa, Kenya - (MBA)).