Cloudflare system status
SSL Issuance Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 4 months ago. Mar 17, 2017 - 16:13 UTC
Identified
SSL certificate issuance is currently delayed for new Cloudflare customers. We are currently working to eliminate these delays.
Posted 4 months ago. Mar 16, 2017 - 22:12 UTC
This incident affected: Cloudflare customer dashboard and APIs (SSL Certificates).