Cloudflare System Status

DNS Update Delays in Singapore, Mumbai, New Delhi, Chennai
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Feb 20, 2017 - 15:32 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted Feb 20, 2017 - 12:32 UTC
Identified
We are monitoring delays and working on improving these currently
Posted Feb 20, 2017 - 11:02 UTC
Investigating
Cloudflare is investigating delays in making updates to DNS records.
We are observing delays of up to 90 minutes in updates to DNS records. Cloudflare's DNS service delivery is still available: only DNS updates and changes are delayed.
Posted Feb 20, 2017 - 11:01 UTC
This incident affected: Asia (Chennai, India - (MAA), Mumbai, India - (BOM), New Delhi, India - (DEL), Singapore, Singapore - (SIN)).