Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 18, 2020 - 02:02 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2020 - 01:36 UTC
Investigating
DNS Update Delays

Cloudflare is investigating DNS-related delays.

We are observing delays of up to 30 minutes in updates to DNS records. Cloudflare's DNS service delivery is still available; only DNS updates and changes are delayed.
Posted Mar 18, 2020 - 01:09 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).