Cloudflare System Status

Investigating network congestion
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Nov 28, 2014 - 17:12 UTC
Monitoring
Network congestion in LAX has been resolved. We continue to monitor it.
Posted Nov 28, 2014 - 16:42 UTC
Investigating
We're receiving reports of network congestion in LAX.
Posted Nov 28, 2014 - 16:28 UTC
This incident affected: North America (Los Angeles, CA, United States - (LAX)).