Cloudflare System Status

Issues with Billing subscription changes
Incident Report for Cloudflare
Resolved
This issue has been resolved.
Posted 5 months ago. Apr 10, 2019 - 04:24 UTC
Update
We are continuing to monitor for any further issues.
Posted 5 months ago. Apr 10, 2019 - 04:24 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.
Posted 5 months ago. Apr 09, 2019 - 05:07 UTC
Identified
Cloudflare is experiencing problems which may cause changes to subscription service plans for some customers. All other services are operating normally.
Posted 5 months ago. Apr 09, 2019 - 01:32 UTC
Update
We are continuing to investigate this issue.
Posted 6 months ago. Apr 08, 2019 - 19:59 UTC
Investigating
Cloudflare is experiencing a problem with the Billing platform, which is causing customers to receive an erroneous email.

This will not impact customer domain registration services on Cloudflare.
Posted 6 months ago. Apr 08, 2019 - 18:28 UTC
This incident affected: Cloudflare Sites and Services (Billing).