Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This issue has been resolved and DNS update services have returned to normal.
Posted 7 months ago. Mar 08, 2018 - 14:45 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted 7 months ago. Mar 08, 2018 - 14:32 UTC
Investigating
Cloudflare is investigating delays of up to 15 minutes when making updates to DNS records. DNS resolution is still performing correctly - only record updates and changes are delayed.
Posted 7 months ago. Mar 08, 2018 - 14:26 UTC