Cloudflare System Status

DNS delays
Incident Report for Cloudflare
Resolved
This issue has been resolved.
Posted 9 months ago. Jan 16, 2019 - 07:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 9 months ago. Jan 16, 2019 - 04:24 UTC
Identified
The issue has been identified and a fix is being implemented. We will update once we have confirmed it is working.
Posted 9 months ago. Jan 16, 2019 - 04:09 UTC
Investigating
Cloudflare is investigating DNS-related delays.
We are observing delays of up to 60 minutes in updates to DNS records. Cloudflare's DNS service delivery is still available; only DNS updates and changes are delayed.
Posted 9 months ago. Jan 16, 2019 - 03:55 UTC