Cloudflare System Status

Network Performance Issues in Baghdad, Iraq
Incident Report for Cloudflare
Resolved
This network issue in Baghdad has been resolved and traffic have returned to normal.
Posted 12 months ago. Jun 05, 2018 - 00:33 UTC
Investigating
Cloudflare is observing network performance issues in Baghdad, Iraq. We are actively working to reduce or eliminate any impact to Internet users in this region.
Posted 12 months ago. Jun 04, 2018 - 04:18 UTC
This incident affected: Middle East (Baghdad, Iraq - (BGW)).