Cloudflare system status
Billing Service Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 07, 2017 - 07:08 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted 3 months ago. Aug 06, 2017 - 21:53 UTC
Investigating
We are currently experiencing a billing issue that may cause billing events to be delayed. We are working to get the issue resolved and will update this page as soon as possible.
Posted 3 months ago. Aug 06, 2017 - 00:15 UTC
This incident affected: Cloudflare customer dashboard and APIs (Billing).