Cloudflare System Status

SSL Certificate Provisioning Delays
Incident Report for Cloudflare
Resolved
This issue has been resolved and SSL provisioning has returned to normal.
Posted 8 months ago. Apr 12, 2018 - 19:52 UTC
Identified
Cloudflare is investigating SSL Certificate Provisioning Delays.

We are observing delays of up to 2 hours in provisioning new SSL Certificates. Cloudflare's TLS/SSL service is still available; only provisioning of new SSL Certificates is delayed.
Posted 8 months ago. Apr 12, 2018 - 17:03 UTC
This incident affected: Cloudflare customer dashboard and APIs (SSL Certificates).