Cloudflare System Status

Delay in Email Delivery
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Nov 07, 2019 - 14:53 UTC
Update
The backlog of emails is being reduced. We are continuing to monitor for further issues.
Posted Nov 07, 2019 - 11:03 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 07, 2019 - 07:33 UTC
Investigating
Cloudflare is investigating delay in email delivery that may affect password resets and unrecognized IP address emails. We are actively working to reduce or eliminate any impact to our users.
Posted Nov 07, 2019 - 04:16 UTC