Cloudflare system status
SSL Certificate Provisioning Delays
Incident Report for Cloudflare
Resolved
This issue has been resolved and SSL provisioning has returned to normal.
Posted 2 months ago. Jun 03, 2018 - 12:41 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted 2 months ago. Jun 03, 2018 - 05:59 UTC
Investigating
Cloudflare is investigating SSL Certificate Provisioning Delays.

We are observing delays of up to 4 hours in provisioning new SSL Certificates. Cloudflare's TLS/SSL service is still available; only provisioning of new SSL Certificates is delayed.
Posted 2 months ago. Jun 03, 2018 - 05:50 UTC
This incident affected: Cloudflare customer dashboard and APIs (SSL Certificates).