Cloudflare System Status

SSL Delays
Incident Report for Cloudflare
Resolved
This issue has now been resolved and SSL provisioning times have returned to normal.
Posted 5 months ago. May 16, 2018 - 10:26 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 5 months ago. May 16, 2018 - 05:39 UTC
Investigating
Cloudflare is investigating SSL Certificate Provisioning Delays.

We are observing delays in deploying new SSL Certificates. Cloudflare's TLS/SSL service is still available; only deployment of new SSL Certificates is delayed.
Posted 5 months ago. May 16, 2018 - 04:44 UTC
This incident affected: Cloudflare customer dashboard and APIs (SSL Certificates).