Cloudflare System Status

Billing Delays
Incident Report for Cloudflare
Resolved
This issue has been resolved
Posted Jul 24, 2017 - 21:36 UTC
Investigating
We are currently upgrading our hardware and you may experience intermittent delays when trying to update your billing profile and/or paid subscriptions.  Please check here for system updates and try again later.
Posted Jul 24, 2017 - 21:17 UTC
This incident affected: Cloudflare Sites and Services (Billing).