Cloudflare System Status

DNS record updates delayed in West North America region
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 02, 2015 - 16:36 UTC
Investigating
We are currently investigating this issue.
Posted May 02, 2015 - 16:22 UTC