Cloudflare System Status

DNS Update Delays in Montreal
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 23, 2018 - 13:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2018 - 09:55 UTC
Investigating
Cloudflare is investigating delays of up to 30 minutes in making updates to DNS records in Montreal. DNS resolution is still performing correctly - only record updates and changes are delayed.
Posted Apr 23, 2018 - 09:40 UTC