Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
Cloudflare has resolved this issue and DNS updates have resumed normal operation.
Posted 4 months ago. Apr 29, 2019 - 16:05 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted 4 months ago. Apr 29, 2019 - 12:18 UTC
Investigating
Cloudflare is investigating delays of up to 30 minutes in updates to DNS records. These delays only affect record changes and updates.

DNS resolution is operating normally.
Posted 4 months ago. Apr 29, 2019 - 11:44 UTC
This incident affected: Cloudflare Sites and Services (DNS Updates).