Cloudflare System Status

Network Performance Issue in Wuxi
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 22, 2020 - 11:34 UTC
Monitoring
A remediative action has been taken and we are monitoring the results.
Posted May 22, 2020 - 06:38 UTC
Investigating
Cloudflare is investigating issues with network performance in Wuxi, China.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted May 22, 2020 - 04:24 UTC
This incident affected: Asia (Wuxi, China - (WUX)).