Cloudflare System Status

DNS delays
Incident Report for Cloudflare
Resolved
This has now been resolved.
Posted Nov 30, 2016 - 15:50 UTC
Monitoring
We are working to mitigate this and are currently seeing the DNS delays decrease.
Posted Nov 30, 2016 - 15:34 UTC
Investigating
Cloudflare is investigating DNS-related delays.
We are observing delays of up to 1.39 hours in updates to DNS records. Cloudflare's DNS service delivery is still available; only DNS updates and changes are delayed.
Posted Nov 30, 2016 - 14:05 UTC