Cloudflare system status
Billing Issues
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 06, 2017 - 17:17 UTC
Monitoring
We have identified the issue with processing payments and have implemented a fix.
Posted about 2 months ago. Jan 06, 2017 - 17:06 UTC
Investigating
We are having trouble processing payments. We are investigating the problem and will update as soon as we have implemented a fix.
Posted about 2 months ago. Jan 06, 2017 - 16:06 UTC
This incident affected: Cloudflare customer dashboard and APIs (Billing).