Cloudflare system status
DNS and Load-Balancer Update Delays
Incident Report for Cloudflare
Resolved
This issue has been resolved and DNS and Load-Balancing updates are now propagating normally.
Posted 26 days ago. May 29, 2018 - 23:41 UTC
Monitoring
We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted 26 days ago. May 29, 2018 - 23:06 UTC
Identified
The issue has been identified and a fix is being implemented. We will update once we have confirmed it is working.
Posted 26 days ago. May 29, 2018 - 18:23 UTC
Investigating
We are observing delays of up to 30 minutes in updates to DNS and Load-Balancer records. Cloudflare's DNS service delivery is still available; only DNS updates and changes are delayed.”
Posted 26 days ago. May 29, 2018 - 18:00 UTC