Cloudflare System Status

DNS updates delays
Incident Report for Cloudflare
Resolved
This issue has now been resolved.
Posted Oct 24, 2016 - 13:05 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 24, 2016 - 11:57 UTC
Investigating
We are observing delays of up to 20 minutes in updates to DNS records. CloudFlare's DNS service delivery is still available; only DNS updates and changes are delayed.
Posted Oct 24, 2016 - 11:57 UTC