Cloudflare System Status

DNS Update Delays in Yerevan, Armenia
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Aug 23, 2017 - 09:19 UTC
Investigating
Cloudflare is investigating delays of up to 60 minutes in making updates to DNS records in Yerevan, Armenia. DNS resolution is still performing correctly - only record updates and changes are delayed.
Posted Aug 23, 2017 - 08:39 UTC
This incident affected: Asia (Yerevan, Armenia - (EVN)).