Cloudflare System Status

Investigating Purge delays
Incident Report for Cloudflare
Resolved
We have identified the cause of Purge delays and resolved the issue.
Posted Aug 09, 2015 - 19:58 UTC
Investigating
We are investigating the cause of 30-60 minute delays in some PURGE requests.
Posted Aug 09, 2015 - 19:10 UTC